Computer upgrade status

On Tuesday, the new 500GB seagate hard drives arrived at the house. This was to be my first experience setting up drives in a RAID configuration let alone installing a windows operating system onto it — definitely a learning experience!

Desired setup:

  • RAID 0 (performance) using two 500GB hard drives for a total capacity of 1TB
  • Windows Vista Business 64-bit edition with 8GB of RAM

The installation proceeded with me disconnecting all cables, opening the case, and loading the two hard drives into an internal bay in the case. This was the easy part – 30 minutes if you include all the unwrapping, unpacking, etc.

Next, it was time to use the BIOS utility to create the RAID volume. This was also a snap, once I figured out that you had to hit tab to see the POST messages before hitting the designated key combination of Ctrl+i to access the hidden RAID utility built into the BIOS. Again, no problem — 10 minutes with a couple reboots.

Finally, I was ready for the Windows Vista installation. This is where I ran into a number of problems with the installer. I had already determined from my initial research that there is no “winging it” with the windows installation. You MUST have the correct driver for your RAID controller – there is no generic controller included with the Windows installation media that works for a RAID drive — if the driver for your particular RAID controller is not included in the Windows installation package, then you must have your manufacturer’s driver to proceed with the installation. There is a special screen in the Windows Vista installation where you can load a driver for asking your hard drive. I was able to download the driver onto a USB flash drive and have the Windows installer pick up that driver, but I was still receiving a “Windows cannot find a volume that meets system requirements” error. I tried several different versions of the driver, but none of them worked. Finally, I tried updating the BIOS even though the factory-installed BIOS was only a few months old. Bingo! The install worked perfectly on the next attempt!

Once I had everything up and running, I was able to run PC Mark Vantage and this time, I did notice a marked improvement over my current development machine — almost twice as fast! Also my Windows Vista user experience score maxed out the Processor, Memory, and Primary hard disk categories with a 5.9 in each (the maximum rating). My graphics and gaming graphics are still weak, but my new entry level gaming graphics card ATI HD4670 is going to be here next week and that should take care of that. I am hoping to dive into the field of GPGPU (general-purpose computation using graphics processing units integrated into modern graphics cards) and take advantage of the extreme parallelism found in modern graphics cards to create maps even faster.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s